Deployment Node.js no Debian 7 x86-64 bits

Dias atrás, conheci uma galera que está iniciando um startup já um tempo e se deram bem no mundo dos negócios, criando um GW de pagamento baseado em Node.js, então achei legal pesquisar (nos próximos posts falo mais sobre Node.js e suas vantagens):

Para deployment Node.js no Debian 7 x86-64 bits

$ sudo apt-get update && apt-get install git-core curl build-essential openssl libssl-dev

$ git clone https://github.com/joyent/node.git

$ cd node

$ sudo su –

# ./configure –openssl-libpath=/usr/lib/ssl
# make
# make test (ctrl+c se demorar demais os tests.)
# make install
# node -v

root@akrivis:~/node# node -v
v0.11.7-pre

Instalando npm (um espécie de instalador de módulos que está para node.js, assim, como está rubygems para ruby, easy_install ou pip para python, cpan para perl e por ai vai…):

wget http://npmjs.org/install.sh

sh install.sh

root@akrivis:~/node# npm update
root@akrivis:~/node# npm -h

Usage: npm <command>

where <command> is one of:
add-user, adduser, apihelp, author, bin, bugs, c, cache,
completion, config, ddp, dedupe, deprecate, docs, edit,
explore, faq, find, find-dupes, get, help, help-search,
home, i, info, init, install, isntall, issues, la, link,
list, ll, ln, login, ls, outdated, owner, pack, prefix,
prune, publish, r, rb, rebuild, remove, repo, restart, rm,
root, run-script, s, se, search, set, show, shrinkwrap,
star, stars, start, stop, submodule, tag, test, tst, un,
uninstall, unlink, unpublish, unstar, up, update, v,
version, view, whoami

npm <cmd> -h quick help on <cmd>
npm -l display full usage info
npm faq commonly asked questions
npm help <term> search for help on <term>
npm help npm involved overview

Specify configs in the ini-formatted file:
/root/.npmrc
or on the command line via: npm <command> –key value
Config info can be viewed via: npm help config

npm@1.3.9 /usr/local/lib/node_modules/npm

@firebitsbr

Uma resposta para “Deployment Node.js no Debian 7 x86-64 bits

  1. Foi legal, compilar pelo git, acho que a versão que estava usando era UNSTABLE, node 11.07-pre e ao tentar fazer update no npm para alguns requires, tem erros.

    O esquema é fazer download da versão Current Version: v0.10.17 do site, node.org (28-08-2013) e continuar o Howto do post que eu fiz.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s